[Beta 3.9.0] Problem with Edit Bank [SOLVED]

Hello weird problem here with the bank settings. Firmware 3.9 and beta editor used.

I’m not able to save or change bank settings beyond a certain point. For example on a new bank i can add things (On Enter events for example), but i’m not able to change them or add new events afterwards: If i save my changes things revert back to the previous state. It’s not only events but also simple things like the bank Name.


Just to check, are you using the latest v3.9? what filename is the file dated at?

as it’s in beta state, we’re still pushing new firmware updates, and updating the staging editor as well. so if you’re using an older v3.9 firmware, there might be some issues with using the editor.

Not sure. Downloaded it in july.
But i will try to update to the last you have and will tell you if the problem is still there.

OK, just re-updated with the 24/7 file (i belkieve it’s the last one) and editor 1.1.6 Beta, and still the same problem.

For example if i want to change the name of a bank and click “Save” the unit does react but the name don’t change.

Presets are working ok (names, events), but not banks.

I just tested it with the MC6 and MC8 and couldn’t reproduce the issue. The bank names and messages saves correctly.

Which model are you using? So the controller shows “Updating bank x” when you click on Save Bank Settings, but it does not reflect in the controller? Are you connected directly via USB to the computer, or using some other interface (eg WIDI) ?

Are you definitely using the staging editor version and not the ‘live’ version? 3.9.0 won’t work properly with the live version of the editor.

Yes. And the one for 3.9.0 and above.

So strange you can’t reproduce. Maybe i should reinstall this update, or try a different cable/USB port maybe something went wrong.

I’m using a MC6 mkII with black screen (white letters).
When i update it does reflect on the unit (Updating bank message).
Directly connected to the computer with USB cable.

Is it possible to take a video of this issue and send it to us? Just so I’m not missing anything.

I will try to make this video but i’ve got more informations for you.
Actually i can save for some banks, not all banks. But some of them are like “corrupted”.
There is a difference in the editor between “clean” banks and “corrupted” ones.

On a “clean” banks, all the non-used messages messages are filled with Nothing (Event) and Empty (Type). On those banks i can save and make changes.

On “corrupted” banks, all the non used messages are blank.

I think that’s a clue so I uploaded screenshots for you:



Now i need to figure how to clean those banks since i can’t save.

More news.

I discovered that if i copy a clean bank and paste it over a corrupted one, it works.
Now this bank is clean again and can be edited. So my problem is kinda solved.

Note that just correcting the blank things to Nothing/Empty does not work, it has to be copy/paste.

Everythiing working fine now (i had to recreate some banks but no big deal).
I don’t know how those bank were “corrupted”, probably a bad update somewhere in the past.
Thanks for your help anyway.

thanks for the information! I think I came across this before - must be a bug somewhere. I’ll try to replicate this and find out the issue, but yes, it looks like the editor is receiving some invalid values.