Bank Change - Load preset not working

Hi guys,

I’m having an issue when changing banks as I want to automatically load presets.
Let’s say I want to bank up from 2>3 and then bank down from 3<2 and always have a preset engaged when entering the bank.
This works the first time, the second will not, the third time will work again, and so on.

I looked at the video tutorial " Bank Presets: Send MIDI Messages by Entering or Exiting a Bank" but for whatever reason, it won’t work on my end.
I’m running two Empress pedals through an MC3 - firmware 3.8.8
I’m attaching screenshots with my settings.

Any ideas?

Thanks a lot
Doru




Hey Doru, so that we can diagnose the problem, what do you mean it only works the first time and not the second? Does it only work going from 2>3, and not 3>2?

I think this might have to do with the preset toggle settings. On your first try, only the Pos 1 messages engage. On your second try, it should only be the Pos 2 messages engaging. Did you check in the MIDI Monitor?

I can test your settings tomorrow

It works just in odd sequence.
Let’s say I’m just bouncing back and forth between these two banks.

Sequence 1

2>3 ok
3> 2 ok

Sequence 2 (repeat the steps above)

2>3 not working
3> 2 not working

Sequence 3 (repeat the steps above)

2>3 ok
3> 2 ok

Doru

James, you are right. If I do not use the toggle option everything works fine, but the toggle option is really helpful.
I spotted what is happening in the MIDI monitor but I do not know what and where to fix.
I’m attaching a screenshot with my MIDI monitor.

Thanks!
Doru

Try making the same messages for Pos2 as Pos1, or setting them all to Both (then turn off Toggle Mode and add a Toggle Preset message on Press to keep the Blink). Right now it seems you only have the one message on Pos2, which is why it’s only executing that message every other time.

How about adding an additional Set Toggle message on entering the bank, before the engage preset message, so that you can clear the toggles before the preset engages.

1 Like

Guys,

It works and I want to thank both of you for the support.
Toggle Mode is now set to OFF but I have a toggle preset action as Quasar suggested.
I’m attaching a print screen with the current state hoping to be of use for someone who might encounter a similar issue.

Thanks again!
Doru

2 Likes