Aux Switches Always Send Message Twice

I’m using aux switches to engage presets on my MC6 Pro but every time I hit the switches, they send whatever message I have on the preset twice. I am fairly certain it’s not a problem with the physical switches. I made the switches with momentary soft switches. I’m an audio engineer and I’ve made a lot of pedals, synths, mics, rack gear, etc. so a simple switch pedal is not a challenge . I also checked the schematic in the manual to make sure I used the diodes properly for the tip+ring switch but it still sends the message twice on all switches no matter what I do. I have tried making the preset either a press or release, same thing. I have tried ruling out the physical switches by just pressing two alligator clips together, same thing. Has anyone experienced this?


I can’t quite explain it but this stopped happening. I had some other buggy behavior after the firmware update that started occurring but resolved after resaving controller settings. This may be similar.

It may be just the editor showing the message twice. I don’t think it is from the controller. You can also verify it using www.midimonitor.com.

I’ll need to check it out.

Do note that the MC has 4 virtual MIDI ports, so if in the controller settings, the USB virtual MIDI ports is set to 2 (or more), then you’ll see multiple messages in the MIDI monitor.

2 Likes

I can’t say for sure why but it stopped happening. After upgrading firmware, I had some weird behaviours until I resaved controller settings and this is probably one of them.